Current Programming Naming Conventions Suck

Timlah's Gravatar image
Written by: Timlah | Written on: 1 Apr 2025 | Estimated reading time: 3 minutes

Being a full-stack developer, I find myself constantly running into issues with naming conventions. I thought I'd run through some variable conventions I see in my day-to-day coding tasks, break them down as to why they're not so good and introduce a type that you don't see every day - But one that I think has the potential to solve all of the problems and bring all of us together, in unison, to better enjoy our craft.

The conventions we'll discuss and the obfuscated true convention

camelCase

camelCase, this is the bread and butter style that I'm used to. As a Scala developer, we all tend to gravitate towards camelCase. As the stylisation shows, you start off lowercase, then for each word in a variable name, you do an uppercase for the first letter of the word. For instance, if your variable is to be called "my variable", you would stylise this as myVariable.

camelCase is good, don't get me wrong, but it's not that good. For those of us who like grammatically correct English, the first word not being capitalised makes for a strange juxtaposition to what we're used to. For someone who is learning a language, they may be trying to get their heads around the language and following all of the rules of it. Capitalisation is part of the rules of the language, so when they see the first letter not capitalised, they'll be all sorts of confused.

Not good, what a way to confuse people!

snake_case

This is the style you would be most used to seeing in Python. Everything remains lower case, but words are separated out by an underscore, providing some much needed readability between words. Because everything is lowercase, it's less confusing than the capitalisation of camelCase and it's consistant. However, just like everything else, there's quite a big negative to snake_case.

Now, if you happen to be displaying some code in a markdown enabled environment, perhaps you're looking to do a blog post, what could happen when you have three words?

my snake variable

Oh no! This is terrible! Now we're suddenly going to have things be italicised when we just wanted to make a variable name. Curses!

kebab-case

Ahh kebab-case. Now we're talking! A truly hunger-inducing naming convention. Skewer the words together, there's no mistaking this one. Surely, this must be the right option. No more wrong uppercases, the en dashes (-) don't cause any problems with markdown. This can't possibly be a bad convention to use... Right..?

So it turns out, backend developers have nightmares when they think of frontend development. The moment you whisper the three letters css, they determine you are speaking in tongues. Oh sure, backend developers are comfortable with changing the colour of a font, say to color: #4A412A - But that colour is proof you're a menace to the visual senses. So ids and classes written in kebab-case, no. Backend devs will just close their IDE as this convention is for those fancy css-writing frontend devs.

Now go centre a <div>... or something!

So is PascalCase the right convention?

Are you kidding me? We've already seen the disaster camelCase caused.

No, it's time for something completely different. We can't capitalise based on words, no more skewers, no more en dashes.

Introducing SpOnGeBoBcAsE!

No more will people question your variable naming! Never again will people gaze in disgust at your dreadful code. No one will ask if AI wrote the code for you, no, because they'll see your variables and be stunned! They'll see that you are a visionary and a darn good programmer at that. You know all of those developers who use an anime profile picture? Pathetic, you'll join the crew of developers all with this as their profile image:

SpOnGeBoBcAsE dEvS fOr LiFe

Anyway, now that you've seen the light and will start to use SpOnGeBoBcAsE in all of your projects, I'd just like to wish you a very happy April Fools!

(P.S, if any screen reader user reads this, I truly apologise.)

Much love to all and happy variable naming - Timlah